Drone CI pipelines failing to run

Incident Report for ACP

Resolved

The issue with Drone pipelines failing has been resolved. New nodes spun up by the cluster autoscaler were missing a required compatibility layer which caused all pipeline steps to fail. The fix has been applied to all affected nodes and pipelines are running successfully again. We are working on a permanent fix to ensure new nodes have this automatically going forward. We apologise for any disruption caused.
Posted May 14, 2026 - 12:01 BST

Update

We are continuing to investigate this issue.
Posted May 14, 2026 - 11:11 BST

Investigating

We are currently investigating an issue where Drone pipelines are failing due to cluster autoscaling issues. As a result, pipeline executions will refuse to run and there will be potential delays in build and deploy processes.

Further updates will be shared once we identify a resolution.
Posted May 14, 2026 - 10:11 BST
This incident affected: Drone Github and Drone Gitlab.