We are currently waiting for the SAM team to complete the procurement of the required Docker Hub license. Once this is finalised, it will resolve the current issue and prevent similar problems in the future. Thank you for your patience.
Posted Dec 08, 2025 - 14:27 GMT
Update
We’re continuing to work on resolving this issue and have identified a solution that will eliminate the rate-limit bottleneck. This solution involves upgrading our Docker Hub license, which is currently in the procurement process. Thank you for your patience while we implement this improvement.
Posted Dec 03, 2025 - 17:04 GMT
Identified
The issue has been identified and a temporary fix is being implemented.
Posted Dec 01, 2025 - 15:08 GMT
Investigating
We’re currently experiencing some issues where Drone pipelines may fail to start and Sysdig metrics may not display as expected.
Why is this happening? Docker Hub has daily limits on the number of image pulls. Due to the size of our estate, we’re exceeding these limits which is causing disruptions.
Drone: A temporary workaround is in place to allow pipelines to run, but you may notice delays. If your pipeline fails, please restart it manually.
If you are using Docker Hub: Community Docker Hub images are currently unavailable, so steps using them will not work. Switch to an alternative registry such as ECR or Quay.io.
Sysdig: Some nodes are not reporting Kubernetes metrics to Sysdig. While we investigate, you can use kubectl commands directly on your clusters to gather live service data.
Posted Dec 01, 2025 - 15:07 GMT
This incident affects: Drone Github, Drone Gitlab, and Sysdig.